diff options
author | Gabriel A. Giovanini <mail@gabrielgio.me> | 2022-05-15 16:05:36 +0200 |
---|---|---|
committer | Gabriel A. Giovanini <mail@gabrielgio.me> | 2022-05-15 16:05:36 +0200 |
commit | c434c45380fc6926a5525f97cc4df98a9b3cda94 (patch) | |
tree | 4740520f1ea16f2a5eb2bf62c09c913f3ac21e83 /Cargo.toml | |
parent | 231f2cb2205988cf87062bc9f595307af1ed827f (diff) | |
download | macroblog.rs-c434c45380fc6926a5525f97cc4df98a9b3cda94.tar.gz macroblog.rs-c434c45380fc6926a5525f97cc4df98a9b3cda94.tar.bz2 macroblog.rs-c434c45380fc6926a5525f97cc4df98a9b3cda94.zip |
feat: Add actix http server option
The project has two target bin: actix and hyper.
- Actix is a lot more capable, feature complete and can handle more
request with lower response time but has a bigger memory, size
footprint.
- Hyper is simpler less capable mure with a much smaller footprint.
So by default I'll keep using hyper.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -10,6 +10,7 @@ tokio = { version = "1", features = ["full"] } regex = "1.5" rust-embed = "6.4.0" chrono = "0.4" +actix-web = "4" [profile.release] opt-level = 'z' @@ -21,3 +22,10 @@ strip = true [lib] name="macroblog" path="src/lib.rs" + +[[bin]] +name = "hyper" + + +[[bin]] +name = "actix" |