aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorGabriel A. Giovanini <mail@gabrielgio.me>2022-05-08 21:47:45 +0200
committerGabriel A. Giovanini <mail@gabrielgio.me>2022-05-08 21:47:45 +0200
commitea058a851098bf81cb645249e02d26a8c253db90 (patch)
treec245a133119b1a4bf6168a16c89b22b6e04d319e /Cargo.toml
parent189166e2f44ca69537fa632032ec7ab252595d1b (diff)
downloadmacroblog.rs-ea058a851098bf81cb645249e02d26a8c253db90.tar.gz
macroblog.rs-ea058a851098bf81cb645249e02d26a8c253db90.tar.bz2
macroblog.rs-ea058a851098bf81cb645249e02d26a8c253db90.zip
ref: Add embded rust and router
- Use embed rust to load and resolve file from `content/post` folder, so the whole process is a bit more dynamic. - Add router to to resolve the path. It is the first step to try to get the code a bit cleaner.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 093a4d3..de00d11 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,6 +8,7 @@ sailfish = "0.4.0"
hyper = { version = "0.14", features = ["full"] }
tokio = { version = "1", features = ["full"] }
regex = "1.5"
+rust-embed="6.4.0"
[profile.release]
opt-level = 'z'
@@ -15,3 +16,7 @@ lto = true
codegen-units = 1
panic = 'abort'
strip = true
+
+[lib]
+name="router"
+path="src/router.rs"