aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorGabriel A. Giovanini <mail@gabrielgio.me>2022-05-26 16:40:55 +0200
committerGabriel A. Giovanini <mail@gabrielgio.me>2022-05-26 16:40:55 +0200
commite44658641b75076b702e690df166820c1d133f24 (patch)
tree4f57d70ef6ccac1fa9ce5d840ffb4e638964c00b /Cargo.toml
parentd33e4b11bf059e4a7815a771efcef9d079f0e550 (diff)
downloadmacroblog.rs-e44658641b75076b702e690df166820c1d133f24.tar.gz
macroblog.rs-e44658641b75076b702e690df166820c1d133f24.tar.bz2
macroblog.rs-e44658641b75076b702e690df166820c1d133f24.zip
feat: Move to actix to enable compression
Add compression and enable it by default. Also add `cargo-watch` to watch for changes.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 886081f..c91eeda 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,6 +12,9 @@ rust-embed = "6.4.0"
chrono = "0.4"
actix-web = "4"
+[dev-dependencies]
+cargo-watch = "8.1.1"
+
[profile.release]
opt-level = 'z'
lto = true
@@ -26,6 +29,5 @@ path="src/lib.rs"
[[bin]]
name = "hyper"
-
[[bin]]
name = "actix"