aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 0 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d94285f..97ceee6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,23 +14,12 @@ default = ["console_error_panic_hook"]
wasm-bindgen = "0.2.63"
getrandom = { version = "0.2", features = ["js"] }
rand = "0.8.5"
-
-# The `console_error_panic_hook` crate provides better debugging of panics by
-# logging them with `console.error`. This is great for development, but requires
-# all the `std::fmt` and `std::panicking` infrastructure, so isn't great for
-# code size when deploying.
console_error_panic_hook = { version = "0.1.6", optional = true }
-# `wee_alloc` is a tiny allocator for wasm that is only ~1K in code size
-# compared to the default allocator's ~10K. It is slower than the default
-# allocator, however.
-#
-# Unfortunately, `wee_alloc` requires nightly Rust when targeting wasm for now.
wee_alloc = { version = "0.4.5", optional = true }
[dev-dependencies]
wasm-bindgen-test = "0.3.13"
[profile.release]
-# Tell `rustc` to optimize for small code size.
opt-level = "s"