aboutsummaryrefslogtreecommitdiff
path: root/importer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'importer/CMakeLists.txt')
-rw-r--r--importer/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/importer/CMakeLists.txt b/importer/CMakeLists.txt
new file mode 100644
index 0000000..587952e
--- /dev/null
+++ b/importer/CMakeLists.txt
@@ -0,0 +1,9 @@
+project(dict_importer VERSION 0.1 LANGUAGES C)
+
+file(GLOB src CONFIGURE_DEPENDS "*.c")
+add_executable(dict_importer ${src})
+
+target_compile_options(dict_importer PRIVATE -Wall -Wextra -Wpedantic -Werror)
+target_include_directories(dict_importer PUBLIC "${PROJECT_BINARY_DIR}" "${PROJECT_SOURCE_DIR}")
+target_link_libraries(dict_importer sqlite3 lib)
+