aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGabriel A. Giovanini <mail@gabrielgio.me>2024-02-12 13:34:56 +0100
committerGabriel A. Giovanini <g.giovanini@gridx.de>2024-02-14 12:29:25 +0100
commitfc26d6542276e17f3206a00b996162397d875e93 (patch)
tree755683100beb190eb8c5983d77fdbdc041f20647 /CMakeLists.txt
downloaddict-fc26d6542276e17f3206a00b996162397d875e93.tar.gz
dict-fc26d6542276e17f3206a00b996162397d875e93.tar.bz2
dict-fc26d6542276e17f3206a00b996162397d875e93.zip
feat: Initial commit
Add initial code form dealing with sqlite.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..2614aa6
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.26)
+
+project(dict VERSION 0.1 LANGUAGES C)
+
+file(GLOB src CONFIGURE_DEPENDS "*.h" "*.c")
+add_executable(dict ${src})
+
+target_compile_options(dict PRIVATE -Wall -Wextra -Wpedantic -Werror)
+target_include_directories(dict PUBLIC "${PROJECT_BINARY_DIR}")
+target_link_libraries(dict sqlite3)
+