aboutsummaryrefslogtreecommitdiff
path: root/apks/tres/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'apks/tres/APKBUILD')
-rw-r--r--apks/tres/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/apks/tres/APKBUILD b/apks/tres/APKBUILD
new file mode 100644
index 0000000..a9c7f73
--- /dev/null
+++ b/apks/tres/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gabriel Arakaki Giovanini <mail@gabrielgio.me>
+pkgname=tres
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Simple rule of tree"
+url="https://git.sr.ht/~gabrielgio/tres"
+arch="noarch"
+license="MIT"
+options="!check" # this can't be tested
+builddir="$srcdir/$pkgname-$pkgver/"
+subpackages="$pkgname-nginx:_nginx:noarch"
+
+source="
+ https://artifacts.gabrielgio.me/archive/$pkgname/$pkgname-$pkgver.tar.gz
+ "$pkgname".nginx.conf
+"
+
+build() {
+ echo "skipping build"
+}
+
+_nginx() {
+ depends="nginx tres"
+ pkgdesc="nginx configuration for $pkgname"
+ install -Dm644 "$srcdir"/"$package"/"$pkgname".nginx.conf \
+ "$subpkgdir"/etc/nginx/http.d/"$pkgname".nginx.conf
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/webapps/"$pkgname"
+ cp -dr index.html "$pkgdir"/usr/share/webapps/"$pkgname"
+}
+
+sha512sums="
+c8a10539b56026804843c62ff423ad5cc596fd49a04be4642f6319f2110679388554d0e45ea1928d7d2b8791e46b49d3d3a8d43c9c9d79d5ca96af5eea6ead64 tres-0.1.0.tar.gz
+8dcf6312a400ce876d09bf2e050f50151c6a8f56bc8d7157e2769274ea472831601a7a2c9795d3eba64fe33ca0eaf723681e7ec3944b8ba61fde8df8a067cba0 tres.nginx.conf
+"