aboutsummaryrefslogtreecommitdiff
path: root/apks/qtc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'apks/qtc/APKBUILD')
-rw-r--r--apks/qtc/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/apks/qtc/APKBUILD b/apks/qtc/APKBUILD
new file mode 100644
index 0000000..cbf570d
--- /dev/null
+++ b/apks/qtc/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gabriel A. Giovanini <mail@gabriegio.me>
+pkgname=qtc
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="Template compiler (converter) for quicktemplate"
+url="https://github.com/valyala/quicktemplate/tree/master"
+arch="x86_64"
+license="MIT"
+makedepends="go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/valyala/quicktemplate/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/quicktemplate-$pkgver"
+
+build() {
+ go build ./qtc/main.go
+}
+
+check() {
+ go test ./...
+}
+
+package() {
+ install -Dm755 main "$pkgdir"/usr/bin/qtc
+}
+
+sha512sums="
+b7f700bafcb63d7c86741579234a32b470aa671993235ea2806545f8a4e3cf23c4464489b73af08ce2e0d8ec2185dadb24e3d73f47403d7cd02b0da9f46497da qtc-1.7.0.tar.gz
+"