aboutsummaryrefslogtreecommitdiff
path: root/apks/py3-nextcloud-api-wrapper/APKBUILD
diff options
context:
space:
mode:
authorGabriel Arakaki Giovanini <mail@gabrielgio.me>2022-10-14 22:13:38 +0200
committerGabriel Arakaki Giovanini <mail@gabrielgio.me>2022-10-14 22:13:38 +0200
commite4390dd34e24ee97145bc3e9f717430db9745da3 (patch)
tree425afeb3b7bbdad0b4d26dd3fee350f71c7243ee /apks/py3-nextcloud-api-wrapper/APKBUILD
parentdea84da8bb781552be49070a56deb87234bbb399 (diff)
downloadapkbuilds-e4390dd34e24ee97145bc3e9f717430db9745da3.tar.gz
apkbuilds-e4390dd34e24ee97145bc3e9f717430db9745da3.tar.bz2
apkbuilds-e4390dd34e24ee97145bc3e9f717430db9745da3.zip
fix: rename folder to match package's name
This makes the whole thing a bit easier
Diffstat (limited to 'apks/py3-nextcloud-api-wrapper/APKBUILD')
-rw-r--r--apks/py3-nextcloud-api-wrapper/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/apks/py3-nextcloud-api-wrapper/APKBUILD b/apks/py3-nextcloud-api-wrapper/APKBUILD
new file mode 100644
index 0000000..4b3bafe
--- /dev/null
+++ b/apks/py3-nextcloud-api-wrapper/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gabriel Arakaki Giovanini <mail@gabrielgio.me>
+pkgname=py3-nextcloud-api-wrapper
+_pkgorig=nextcloud-API
+pkgver=0.2.3
+pkgrel=0
+pkgdesc="Python wrapper for NextCloud api"
+url="https://github.com/luffah/nextcloud-API"
+arch="noarch"
+license="GPL-3.0"
+option="!check" #check requires docker
+depends="python3 py3-requests"
+makedepends="python3-dev py3-setuptools_scm"
+source="$pkgname-$pkgver.tar.gz::https://github.com/luffah/nextcloud-API/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgorig-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="
+71200082db3ca9069284931123fa184921c1d8ae0037d51763e9146a1aabac33c791fbcb766071921718fc8aefb32ca403e6c80c4c3890e37699d10877dbb6df py3-nextcloud-api-wrapper-0.2.3.tar.gz
+"