aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 48967ff..adde93c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -7,7 +7,7 @@ repository = "https://git.sr.ht/~gabrielgio/reddit-nextcloud-importer"
description = "Reddit to Nextcloud importer"
authors = ["Gabriel Arakaki Giovanini <mail@gabielgio.me>"]
packages = [
- { include = "reddit-nextcloud-importer" }
+ { include = "reddit_nextcloud_importer" }
]
[tool.poetry.dependencies]
@@ -25,6 +25,10 @@ coverage = "^6.3.2"
pytest-mock = "^3.7.0"
pytest-cov = "^3.0.0"
+
+[tool.poetry.scripts]
+reddit-nextcloud-importer = "reddit_nextcloud_importer:main"
+
[build-system]
requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api"