aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..2c78da1
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,24 @@
+[tool.poetry]
+name = "reddit-nextcloud-importer"
+version = "0.1.0"
+description = "Reddit to Nextcloud importer"
+authors = ["gabrielgio <gabriel.giovanini@pm.me>"]
+
+[tool.poetry.dependencies]
+python = "^3.10"
+gallery-dl = "^1.20.5"
+jsonpickle = "^2.1.0"
+nextcloud-api-wrapper = "^0.2.1"
+requests = "^2.27.1"
+praw = "^7.5.0"
+
+[tool.poetry.dev-dependencies]
+pytest = "^7.0.1"
+pytest-xdist = "^2.5.0"
+coverage = "^6.3.2"
+pytest-mock = "^3.7.0"
+pytest-cov = "^3.0.0"
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"