aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorgabrielgio <gabriel.giovanini@pm.me>2022-02-22 01:02:17 +0100
committergabrielgio <gabriel.giovanini@pm.me>2022-02-22 01:02:17 +0100
commit4bf7a7eea37ce39abd304f35f02a4ea39f81a8f2 (patch)
treea9499c0f778e516cbb61f40293fe5f11403e9288 /pyproject.toml
parentb8d69f9bf5a03fd6d8b6a477f3b7ca8f10c27bda (diff)
downloadreddit-nextcloud-importer-4bf7a7eea37ce39abd304f35f02a4ea39f81a8f2.tar.gz
reddit-nextcloud-importer-4bf7a7eea37ce39abd304f35f02a4ea39f81a8f2.tar.bz2
reddit-nextcloud-importer-4bf7a7eea37ce39abd304f35f02a4ea39f81a8f2.zip
feat: Migrate to poetry
Migrates from virtual env to poetry. Also update python packages.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..2c78da1
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,24 @@
+[tool.poetry]
+name = "reddit-nextcloud-importer"
+version = "0.1.0"
+description = "Reddit to Nextcloud importer"
+authors = ["gabrielgio <gabriel.giovanini@pm.me>"]
+
+[tool.poetry.dependencies]
+python = "^3.10"
+gallery-dl = "^1.20.5"
+jsonpickle = "^2.1.0"
+nextcloud-api-wrapper = "^0.2.1"
+requests = "^2.27.1"
+praw = "^7.5.0"
+
+[tool.poetry.dev-dependencies]
+pytest = "^7.0.1"
+pytest-xdist = "^2.5.0"
+coverage = "^6.3.2"
+pytest-mock = "^3.7.0"
+pytest-cov = "^3.0.0"
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"