aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGabriel A. Giovanini <mail@gabrielgio.me>2024-03-13 21:17:51 +0100
committerGabriel A. Giovanini <mail@gabrielgio.me>2024-03-18 11:58:15 +0100
commitb3d0af2de29711abfe6da373786d365d9a6de198 (patch)
tree6b8c59999b323e426a1b64781f0b02fc70f229df /setup.py
parentecabdfaf915887dbd91b6742d0fc1bf81cf336a0 (diff)
downloadjnfilter-b3d0af2de29711abfe6da373786d365d9a6de198.tar.gz
jnfilter-b3d0af2de29711abfe6da373786d365d9a6de198.tar.bz2
jnfilter-b3d0af2de29711abfe6da373786d365d9a6de198.zip
feat: Rewrite to golangv0.1.3
I have found a nice lib in go to handle XML so I migrate to it. Go is ages easier to deploy then python.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 0 insertions, 23 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 7692d27..0000000
--- a/setup.py
+++ /dev/null
@@ -1,23 +0,0 @@
-from setuptools import setup
-
-requirements = [
- 'httpx==0.21.1',
- 'flask==2.2.2',
-]
-
-
-setup(name='jnfilter',
- version='0.3.0',
- description='A FastAPI server to filter Nercast podcast feed',
- url='https://git.sr.ht/~gabrielgio/jnfilter',
- author='Gabriel Arakaki Giovanini',
- author_email='mail@gabrielgio.me',
- license='MIT',
- packages=['jnfilter'],
- entry_points={
- 'console_scripts': [
- 'jnfilterd=jnfilter',
- ]
- },
- install_requires=requirements,
- zip_safe=False)