aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGabriel Arakaki Giovanini <mail@gabrielgio.me>2022-12-28 01:18:54 +0100
committerGabriel Arakaki Giovanini <mail@gabrielgio.me>2022-12-28 01:18:54 +0100
commit9017f48371ecdb1408f793b0771d5f5f0fe04acf (patch)
tree3ac7ea2171783021fbaa70c744acc58e7e29f46d /setup.py
parent6f158c70803c3486f263f67619166c697832df72 (diff)
downloadjnfilter-9017f48371ecdb1408f793b0771d5f5f0fe04acf.tar.gz
jnfilter-9017f48371ecdb1408f793b0771d5f5f0fe04acf.tar.bz2
jnfilter-9017f48371ecdb1408f793b0771d5f5f0fe04acf.zip
feat: Move to flask
In my current setup flask is easier to deploy. FastAPI has not yet hit alpine repositories, and I don't want to maintain it myself. Also flask should be more than enough to handle those requests.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 07add82..7692d27 100644
--- a/setup.py
+++ b/setup.py
@@ -2,8 +2,7 @@ from setuptools import setup
requirements = [
'httpx==0.21.1',
- 'fastapi==0.70.0',
- 'uvicorn==0.15.0'
+ 'flask==2.2.2',
]