aboutsummaryrefslogtreecommitdiff
path: root/dict/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'dict/CMakeLists.txt')
-rw-r--r--dict/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/dict/CMakeLists.txt b/dict/CMakeLists.txt
new file mode 100644
index 0000000..051635b
--- /dev/null
+++ b/dict/CMakeLists.txt
@@ -0,0 +1,6 @@
+file(GLOB src CONFIGURE_DEPENDS "*.c")
+add_executable(dict ${src})
+
+target_compile_options(dict PRIVATE -Wall -Wextra -Wpedantic -Werror)
+target_include_directories(dict PUBLIC "${PROJECT_BINARY_DIR}")
+target_link_libraries(dict sqlite3 ncursesw m c lib)