aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f253be6..a88fc55 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,12 +2,6 @@ cmake_minimum_required(VERSION 3.26)
project(dict VERSION 0.1 LANGUAGES C)
-file(GLOB src CONFIGURE_DEPENDS "*.h" "*.c")
-add_executable(dict ${src})
-
-target_compile_options(dict PRIVATE -Wall -Wextra -Wpedantic -Werror)
-target_include_directories(dict PUBLIC "${PROJECT_BINARY_DIR}")
-target_link_libraries(dict sqlite3 ncursesw m c)
-
-
add_subdirectory(ext)
+add_subdirectory(importer)
+add_subdirectory(lib)