aboutsummaryrefslogtreecommitdiff
path: root/gallery-dl/APKBUILD
diff options
context:
space:
mode:
authorGabriel Arakaki Giovanini <mail@gabrielgio.me>2022-10-08 20:32:48 +0200
committerGabriel Arakaki Giovanini <mail@gabrielgio.me>2022-10-08 20:51:29 +0200
commit5ae86d77daf952ef6fb5c48128d23d83b60d5119 (patch)
tree38fa89af3ed6479f4c9616b2d65e2b58002204a8 /gallery-dl/APKBUILD
parente7dfcd11bb8eec649cd84f09ddd2b3751dd99952 (diff)
downloadapkbuilds-5ae86d77daf952ef6fb5c48128d23d83b60d5119.tar.gz
apkbuilds-5ae86d77daf952ef6fb5c48128d23d83b60d5119.tar.bz2
apkbuilds-5ae86d77daf952ef6fb5c48128d23d83b60d5119.zip
feat: Add gallery-dl
Adds gallery-dl from testing branch so I don't have to include it in the build process.
Diffstat (limited to 'gallery-dl/APKBUILD')
-rw-r--r--gallery-dl/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/gallery-dl/APKBUILD b/gallery-dl/APKBUILD
new file mode 100644
index 0000000..e503ca3
--- /dev/null
+++ b/gallery-dl/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Hoang Nguyen <folliekazetani@protonmail.com>
+# Maintainer: Hoang Nguyen <folliekazetani@protonmail.com>
+pkgname=gallery-dl
+pkgver=1.23.2
+pkgrel=0
+pkgdesc="CLI tool to download image galleries"
+url="https://github.com/mikf/gallery-dl"
+arch="noarch"
+license="GPL-2.0-or-later"
+option="!check" #check requires docker
+depends="
+ py3-requests
+ python3
+ "
+makedepends="py3-setuptools"
+checkdepends="py3-pytest yt-dlp"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-zsh-completion
+ $pkgname-fish-completion
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/mikf/gallery-dl/archive/v$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+
+ make man completion
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ # Install fish completion to the correct directory
+ rm -r "$pkgdir"/usr/share/fish/vendor_completions.d
+ install -Dm644 data/completion/gallery-dl.fish \
+ -t "$pkgdir"/usr/share/fish/completions
+}
+
+sha512sums="
+75defb234faf0467e5a957594a58a02cfc75180d63a4b2c24d84061d326fbb46f08ad3230b72adf525f1ba82621963564c556047d4aa06c16cc5124ecd8c075f gallery-dl-1.23.2.tar.gz
+"